December 4th, 2008

Eek! So scary!

Printers are the work of the Devil

The plan for yesterday afternoon was to build son-of-custard ... but when I tried to burn a CD of the latest ubuntu server installer it all went horribly wrong (locked up tobias completely). So I switched off tobias & left it, like a wimp. Have to try burning the CD again today - has to happen before I build the server as the burner is going in the server ...

I did end up spending the afternoon sorting out computery stuff anyway - the printer I'd ordered arrived, so I got that installed on my machine. Mostly it Just Worked. Except for the bit that didn't ;) Installed hplip (cups was already there), ran the hp-setup tool, got a test page printed. Printed a test page from the Cups web interface. Tried to print a test page from the Gnome printer stuff (System->Administration->Printing, goodness knows what the thing is called), but failed, miserably. Searched for the error & tried some things that I found as suggested fixes (like changing from the ghostscript-gpl package to the ghostscript-esp package, changed some USE flags ...) and I managed to change the error message, but this one was just as intractible. But then I found a couple of posts in the gentoo forum where people mentioned that everything else seemed to work, just not this one particular fashion of printing a test page. So I fired up Abiword & typed something, and lo & behold! It printed! Got my address label program installed (glabels, it's ace) and it prints too. Still can't print a test page from Gnome, but you know what? I don't much care any more.

Damn annoying to've wasted all that time trying to track down the problem tho, when it was a failure of test page not a failure of printing. I dont really want to revert the changes I made, either, as that might break it ;) Printers are always black magic :/

And now we're almost all set for writing xmas cards. Well, once I double check a couple of addresses, anyway. Now we just have to write the things ;)